Tuesday, 2 August 2011

August Presentation Clicker LP107T and Ubuntu

A while ago, I bought a wireless presenter from a company called August at amazon. Upon arrival, I found that it didn't work with my laptop running Ubuntu 11.04. I was a bit surprised to find this, since the device basically pretends to be a USB keyboard, and hence should run out of the box on any operating system.

A short search led me to this bug report which explains that the linux kernel patch 2.6.37 inadvertently breaks support for the presentation clicker by adding support for the (rather bizarre) Yurex leg shaking sensor. The two gadgets share the same device ID. Since by default Ubuntu let's you choose from a list of recent kernel versions during startup, a simple fix is to choose a pre-2.6.37 kernel version or update your system in case the problem has been fixed in the meantime.

1 comment:

  1. Hi, I've also run into this annoying problem. I recently posted a workaround on my blog that avoids patching the kernel. Since your blog post comes at the top of Google when searching for this issue it might be worth letting people know! My fix is at http://samrelton.wordpress.com/2013/07/17/august-lp107t-driver-linux/#more-25